Back to overview
Degraded

Slow API responses

Sep 30 at 12:44pm GMT+8
Affected services
HitPay Services

Resolved
Sep 30 at 02:05pm GMT+8

We have re-enabled PayNow payments and error rates are now significantly lower.
We are still monitoring the situation to ensure stability.

Updated
Sep 30 at 01:45pm GMT+8

Some of our APIs are slowly recovering, and response times are improving.
However, PayNow payments remain temporarily disabled while we continue to work on a full resolution.

Our team is monitoring closely and will provide further updates as recovery progresses.

Created
Sep 30 at 12:44pm GMT+8

We are currently investigating reports of degraded performance affecting some of our APIs.
Requests may take longer than usual to complete.

Our engineering team is actively working on identifying the root cause and will share an update shortly.