Back to overview
Degraded

PayNow Collections Issue

Sep 11 at 11:19pm GMT+8
Affected services
HitPay Services

Resolved
Sep 12 at 12:27am GMT+8

We’re pleased to inform you that the PayNow collections issue has been resolved. Our banking partner identified the root cause and implemented a fix, and transactions are now processing normally.

Updated
Sep 12 at 12:07am GMT+8

Our banking partner has identified the root cause of the PayNow collections issue and is working on a fix. We will continue to monitor the situation closely and provide further updates as soon as service is fully restored.

Created
Sep 11 at 11:19pm GMT+8

PayNow collections are currently affected due to an ongoing issue at our banking provider. We are working with them to resolve it. Other payment methods remain available. We will share an update as soon as this is fixed. For urgent cases please contact support@hit-pay.com.