Back to overview
Degraded
Issues with Shopify Payments
Aug 20, 2025 at 5:43pm UTC
Affected services
HitPay Services
Resolved
Aug 20, 2025 at 8:00pm UTC
Shopify payments via HitPay has been resolved. Our systems are stable and transaction success rates are back to normal.
Affected services
Created
Aug 20, 2025 at 5:43pm UTC
We are currently experiencing issues with HitPay Shopify Payments. Our team is actively investigating the incident, and we will provide updates as soon as more information is available.
Affected services