Back to overview
Downtime

Temporary Server Glitch

Jul 16 at 03:30pm GMT+8
Affected services
HitPay Services

Resolved
Jul 16 at 03:38pm GMT+8

Incident resolved.
The dashboard.hit-pay.com experienced downtime due to a status 500 error. Multiple checks from different regions confirmed the issue, and the incident was acknowledged quickly. After some time, the monitor recovered automatically from the downtime, resolving the issue without any manual intervention.

Created
Jul 16 at 03:30pm GMT+8

Incident started