Back to overview
Downtime

Timeout (no headers received)

Jul 4, 2025 at 3:17pm UTC
Affected services
HitPay Services

Resolved
Jul 4, 2025 at 3:25pm UTC

Incident resolved.

Created
Jul 4, 2025 at 3:17pm UTC

Incident started