Back to overview
Degraded

Cloudflare Network Outage Impact

Nov 18 at 07:35pm GMT+8
Affected services
HitPay Services
POS Terminal
Checkout Page

Resolved
Nov 18 at 10:40pm GMT+8

Cloudflare has resolved the issue on their end, and systems are returning to normal performance. We are currently not observing elevated error rates across our APIs, dashboard, or POS services. We will continue to monitor closely to ensure full stability.

Created
Nov 18 at 07:35pm GMT+8

We are currently experiencing partial service disruption due to an ongoing Cloudflare infrastructure outage impacting global network routing. As a result, some HitPay services may be intermittently affected, including:
• APIs — delayed responses or occasional failures
• Dashboard access — difficulty logging in or loading pages
• Point of Sale (POS) — intermittent connectivity and sync issues