Back to overview
Downtime

Elevated errors on POS Terminal and Dashboard

Oct 31 at 04:45pm GMT+8
Affected services
HitPay Services
POS Terminal

Resolved
Oct 31 at 05:10pm GMT+8

The elevated error rates affecting POS and Dashboard have been resolved. All services are now operating normally. Online payments were not impacted during this period. Thanks for your patience.

Created
Oct 31 at 04:45pm GMT+8

We are currently seeing increased error rates affecting POS and Dashboard access. Online payments remain fully operational. Our team is investigating and working to restore normal performance.