Back to overview
Downtime

Timeout (no headers received)

Apr 16 at 01:55am GMT+8
Affected services
HitPay Services

Resolved
Apr 16 at 01:57am GMT+8

Incident resolved.
The dashboard for hit-pay.com experienced downtime due to a timeout error where no headers were received, followed by a series of 503 errors across different regions. The issue resolved automatically, with the monitors recovering shortly afterwards in Europe, Australia, and Asia.

Created
Apr 16 at 01:55am GMT+8

Incident started