Back to overview
Downtime

Status 520

Sep 15, 2024 at 9:06pm UTC
Affected services
HitPay Services

Resolved
Sep 15, 2024 at 9:12pm UTC

Incident resolved.

Created
Sep 15, 2024 at 9:06pm UTC

Incident started