Back to overview
Downtime
Status 520
Jun 19 at 05:06am GMT+8
Affected services
HitPay Services
Resolved
Jun 19 at 05:12am GMT+8
Incident resolved.
The dashboard at hit-pay.com went down with a status 520 error, affecting regions in Europe, North America, and Australia. The monitors recovered after a few minutes, and the incident was resolved automatically.
Affected services
Created
Jun 19 at 05:06am GMT+8
Incident started
Affected services